Start a new topic

Beta-Testing Instructions

Prepare your Tappecue Touch and AirProbe

The first step to beta-testing your new AirProbe is putting your Tappecue Touch in Beta-Mode.  You can do this by following the link to Beta-Testing Firmware on your Tappecue Touch.


Once your Tappecue Touch is finished updating to the latest firmware version, we can begin testing the new AirProbe.


Prepare your new AirProbe by inserting your AAA battery into the charging dock.  Charge your new AirProbe for 5 minutes, until fully charged.  By pressing the button on the charging dock, if the green LED light turns on, your probe is fully charged.


Begin a New Session on the Tappecue Mobile App

Start a "test" session on your mobile app.  Your new AirProbe is pre-programed to a specific probe port (one of your choosing).  If you chose "Green" as your color when you purchased, the new AirProbe can only work with the "Green" port (port 1).  When starting a session and selecting your probes, be sure to specify your new AirProbe as a "Dual Sensor" probe with the toggle under "Probe Type".  Select "Slot A" as your internal temperature, and "Slot B" as your chamber temperature.  Note that if you chose a red, black, or blue colored AirProbe, you will need to add your other probes first, before adding your AirProbe.  For example, the red probe is unique to the red probe port, Port 2, so while setting up your session, you must first add Port 1 even if you don't have anything in your first port (you can select "None" as your probe) and then you can continue to add your next probe (your Red AirProbe).   Proceed as normal when setting up the rest of your session.  


Pair your new AirProbe with your Tappecue Touch

Turn on your Tappecue Touch, remove the new AirProbe from its charging dock.  When removed from its charging dock, the AirProbe automatically scans for nearby Bluetooth connections and pair with your powered ON Tappecue Touch.  It is pre-programed to communicate with your Tappecue Touch.  You will see temperatures come through on your device as soon as it's paired.  


Note: for now, only have one Tappecue Touch powered on while linking your AirProbes.


Updates and Problems

We will keep you informed on updates through email.  If you encounter a problem while testing your probes, please "Start a new topic" on the AirProbe Beta forum


Did a second hang test with no hangs.

Did learn constant loss of bluetooth greatly decreases probe duration.


I did a cold test in my fridge and freezer.

I learned that the air probe tip can read negative temps, but the base (chamber) reports 11756 for any negative temps.

The freezer at 0F probe lasted 8h10m.

The fridge at 41F probe lasted 9h30m.

The fridge blocked significant signal, and the freezer more.



Hi James,


It creates another (fake) Tappecue registration called AirProbes.  You would see a session for your Touch and a session for your AirProbes.

So you can use them at the same time, though they are listed under different sessions.


Thanks,

Gina

Great information Michael!


I got my replacement Tappecue after an unsuccessful attempt to downgrade the firmware due to crashing. The new unit took the latest firmware, and there were zero lockups of the Tappecue. Win!


However, during the smoke, I noticed that the reported values from the wired probes (did a meatloaf using Cruise Control and a wired dual probe) were quite noisy. With the prior firmware, temperatures rarely fluctuated unless the probe was removed from the meat or the lid was open on the cooker. Now, even the meat probe fluctuates around. Was an averaging routine removed for this beta? If it was, please put it back.


IMG0011.PNG
(334 KB)

Used the AirProbe this weekend on a pork shoulder. Temps were in very close alignment with a wired dual sensor probe. Had a few spurious zeroes in the chart (please add some logic to filter those out!), which makes the chart hard to read. The AirProbe lasted about 5.5 hrs. 


I tried to charge the probe, and no matter what I did, the button always showed green. Nevertheless I was unable to get the airprobe to connect to the Tappecue for the second part of the cook. Looking at the bottom of the unit, I believe there may be a heavy spot of smoke on the end of the unit, preventing charging. I cleaned it off (I thought), but the charger still thinks the probe is charged. Maybe it is? I can't tell.


Please do something else with the charging light to indicate the true status of the battery in the probe, or have an indicator on the Tappecue that shows the battery status of the probe.

Hi All,


We have sent out an email after 2.2.0 and didn't have anyone saying they were still having lockup issues or loss of WiFi, and several said it fixed when they were.  

We feel the firmware is ready for production and will be releasing it soon as well as launching the AirProbes with the Tappecue Touch in bundles.


We do have both iOS and Android apps in Beta as well and these are not ready to be released.

This is the direct BLE from Probe to App without the Touch.

The signup links for these are as follows.


Here is the link for Android

https://play.google.com/apps/testing/tappecue.app

 

Here is the link for iOS.  You will have to install TestFlight from the App Store first.  Search TestFlight in the App Store to download then click this link:

https://testflight.apple.com/join/ZOzpQi6N



We also have a few test units that are USB charger rather than battery.

These chargers do have the light red if charged, green if not charged.

The probes are also thinner and longer than the ones with the battery charger.


If interested in these probes/chargers let me know.

I've attached photos here.


Thank you!

Gina




photo_1.jpg
(1.35 MB)
photo_2.jpg
(1.29 MB)
Photo_3.jpg
(1.67 MB)

Only photo_2 is viewable.  The other 2 are very small and you can't real view them  :(

That's strange,  They are very large on my browser.

I saved them again smaller.

See if these are any better and thanks!

small1.jpg
(1.1 MB)
small2.jpg
(1.04 MB)
small3.jpg
(1.44 MB)

Now 1 & # are large and 2 is small.  LOL

Tested Monitor AirProbes...Far from smooth....

I downloaded FlightTest and the test Tappecue App,

I selected "AirProbe Monitoring".

I removed my Green AirProbe from the charger and pressed Start.

It did not connect.

I hit Retry.

It still failed to connect.

I replace Green into charger.

I tried my Red AirProbe and it did not connect.

I retried - still no connect.

I verified both probes would connect to my Touch.

They did...then turned my Touch off and returned probes to chargers.

iPhone Bluetooth is definitely on.

Just in case I powercycled my iPhone.

Tried the Red probe twice - failed to connect.

Tried the Green probe....It seemed to find it.

It went into "Connecting..." but reported:

"Sim Card Not Installed" - of course my sim card is installed.

I clicked OK.

After a good long while (a minute or more)

Temps appeared for my red probe.

I pressed "Find More" and removed the Red probe from charger.

New circles appeared but it never connected.

I ended the session and pressed "AirProbe Monitoring" again.

Both probes were on (out of charger).

It when to the screen with two sets of two circles.

It eventually reconnected to the Green Probe.

It still had two empty circles for the Red Probe and said "Connecting..." but never did.

I killed the Tappecue app and restarted it.

Pressed "AirProbe Monitoring"

It went to a screen with circles for the green probe and said connecting.

But it never did.

Both probes were on (out of charger).

I pressed "Find More" and got jumping dots for a while.

But still said connecting (only for green probe).

I put both probes back into chargers.

I killed and restarted the Tappecue app.

I pressed "AirProbe Monitoring".

It opened to a blank lined screen but had no circles.

I pressed "Find More" (getting jumping dots) and removed Red from charger.

In a few seconds it connected.

I pressed "Find More" again (getting jumping dots) and removed Green from charger.

In a few seconds it connected.

Now I thought I had an active 2 AirProbe session.

But there was no "Session Details" button at the bottom.

I pressed back and clicked on "View Current Session"

It reported that I had no active sessions.

I pressed "AirProbe Monitoring".

I reconnected to both probes and now did have "Session Details" at the bottom.


So - Success?

Anyway I will let it gather data for a while with both probes and get an email of the session?

Can I get an email of the session?  How real is this session?

On the first session I killed it asked if I wanted an email or to save the session.

I was said no, and was dubious if it would have worked if I had said yes.


Are there any tests of the app that would be useful?  Let me know.


I would use this on long drives with my dogs and thermo-electric coolers to monitor food temp and air temp at the back of the SUV.


I will let you know how it goes.

Thank you for all the feedback on the iPhone app.

I'm testing as well today so I can add your feedback to mine.


One thing to note, I think the AirProbe should be out of the charger when you press the Find More button.


I do think emailing your session should be good.

One thing I've noticed is that there are some jumps in the temperature readings.

So you may see it drop and then come back up.

This is a bug I've reported.


I'll send in your feedback and let you know if I need more information or clarification.







Oh Michael,  I'm wondering if your Tappecue was still on but charging?

It could have been that the Tappecue still had ahold of them.

The probes will only connect to one device at a time.

No my Touch was not on (except for when I checked the probes were working).


Regarding probe out of charger before clicking Start...It failed both ways.  In fact I am pretty sure in some cases I did not hit start at all...it timed out and tried to connect.


The session email worked normally.

I had no dropouts at all, but my phone was quite near the probes the whole time.

I presume I would get some dropouts with distance/walls between probe and phone.

I am sure my phone would not be able to be more than one yard away from my smoker in this mode (that is what I saw with the Touch with AirProbes inside my smoker).  My smoker blocks RF really well.


There is the continuing issue that the "Graph" function includes all 8 probes even if not all are in use, which messes up the scale on the Graph function.  This scale also gets messed up if there is even one data drop.


Given that the email worked I wonder what would happen if I had zero internet connection...just Bluetooth (which would happen on a road trip).

Login or Signup to post a comment